スポンサーリンク

[cakephp]githubからのCakePHPインストール

githubからのCakePHPインストールする場合

# git clone https://github.com/cakephp/cakephp.git

とするが、これだとmasterが指定されてしまうので、CakePHP3.xがダウンロードされてしまいます。
CakePHP2.x系統がほしい場合はブランチを指定します。
2.8系がほしい場合は以下のようになります。

git clone https://github.com/cakephp/cakephp.git -b 2.8

ブランチの番号は
https://github.com/cakephp/cakephp/
左上のほうにあるブランチの切り替えから確認できます。